Sólo otro blog infame


Menú


Instalando 10.4.3

ADVERTENCIAS

  • Las siguientes instrucciones se refieren al sistema operativo con licencia libre OSX86 desarrollado en Chorrilandia por Bart Simpson.
  • Actúa bajo tu propia responsabilidad, es decir, si haciendo cualquier cosa que leas aquí te cargas algo (o todo) es tu problema.
  • Lo que me ha funcionado a mi no tiene por que funcionarte a ti.

Objetivo y tiempo necesario

Instalar OSX86 en un disco vacío utilizando un sistema con WinXP instalado. En una horita está despachado de sobra.

Aclaración

Existen dos formas de proceder con la instalación, una consiste en quemar la imagen (tras parchearla) a un DVD e instalar normalmente. La otra forma (seguida en la guía) se basa en usar emuladores para evitar el tener que gastar un disco virgen.

Elementos necesarios para la instalación

  • Hardware
    • Un PC con procesador SSE3
    • Un disco duro tipo P-ATA independiente de al menos 6GB
    • Seguramente existan formas de hacerlo funcionar sin SSE3, o con discos duros S-ATA, y mil historias más, pero yo no las he necesitado; así que si es tu caso, rézale a Google y luego publica como lo lograste.
    • Grabadora de DVD, (sólo si quieres hacer la instalación con un DVD grabado)
  • Software, no hace falta decir dónde se puede conseguir esto.
    • WinXP
    • VMWare Workstation 5.5 (no es necesario si optas por grabar el DVD)
    • Daemon Tools (no es necesario si optas por grabar el DVD)
    • UltraISO
    • El parche
    • El fichero de imagen 10.4.3_8f1099_for_dtk_userdvd.dmg que te suministró Bart Simpson por correo certificado en tu domicilio y que es completamente distinto del que circula por las redes p2p.
    • chain0.rar si vas a querer hacer arranque dual desde WinXP

Manos a la obra

  1. Utiliza UltraISO para convertir la imagen DMG a un fichero de tipo ISO. Menú “Herramientas/Convertir…”
  2. Aplica el parche utilizando el programa PPF Patcher que incorpora el mismo
  3. Monta la ISO con Daemon Tools
  4. Arranca VMWare y crea una nueva máquina de tipo Other/Other, asígnale como discos duros, uno virtual residente en cualquier carpeta y además el disco P-ATA de destino, es decir, en el que quieres instalar el nuevo sistema operativo.
  5. Inicia la máquina de VMWare para que arranque desde el DVD (el que estás emulando vía Daemon)
  6. Si todo va bien comenzará la instalación, elije el disco de destino, siguiente, siguiente, siguiente…
  7. Cuando te pida reiniciar apagas la máquina virtual

Situación en este momento

Está instalado WinXP en un disco (imagino que el de arranque) y OSX86 en otro, entonces, ¿como accedemos a OSX86?

  • Método cutre: cambiando el disco de arranque desde la BIOS, más fácil imposible.
  • Método chachi: ya que tienes instalado WinXP puedes usar su gestor de arranque.
    1. Copia chain0 al raiz del disco en que está instalado WinXP,
      normalmente C:
    2. Añade al fichero C:\boot.ini la siguiente línea
      C:\chain0="OSX86"

Si todo te ha funcionado, ¡enhorabuena!.

# OSX86, Monday, 5 de December de 2005 a las 13:09

115 comentarios, amigos del internec

  1. Hola tengo un HP PAVILION P4 2.0 con 756 en ram la placa es una asus con chip i845d baje la version Apple.OS.X.x86.Developer.Kit.Install.DVD-pheNIX y lo parche con la Generic_OSx86_Install_DVD_Patcher_test3

    cree el dvd y todo bien lo queme pero al boteear con el dvd aparece la manzana y ahy se queda pegado lo instale en otro p4 tambien de 2 pero con una placa aopen me pueden decir si el hp q tengo me servira o bajo otra version????

    gracias

    # Cristobal 20 de February de 2006 a las 00:07

  2. Cristobal: La única forma de saberlo es probarlo, simplemente. Por lo que respecta a cuando se te queda pegado en la manzanita gris… a la que te cargue Darwin detén la cuenta atrás y el la linea del boot pon “platform=DCPI” sin las comillas. Si tu DVD/HD tiene actividad es poso probable que se te cuelgue.

    # Backdraft 22 de February de 2006 a las 15:49

  3. Soy nuevo en esto quisiera saber si este mainboard sirve para montar el osx86

    Asrock 775VM800
    LGA775 for Intel Dual Core Exteme Edition / Pentium D / Pentium 4 / Celeron D processors
    FSB 800/533 MHz
    Support advanced Intel EM64T CPU
    Supports Hyper-Threading Technology

    Chipset
    Northbridge: VIA P4M800
    Southbridge: VIA 8237R

    Gracias

    # Orp 23 de February de 2006 a las 16:09

  4. Hola, a ver si alguien me puede ayudar plis, resulta que cuando se ejecuta la instalacion(en el disco duro, no con vmware) va todo bien hasta que muevo el rato o toco alguna tecla de teclado y se cuelga la instalacion, es posible que haya algun problema con los puertos PS2, si alguien me puede ayudar lo agradeceria mucho, saludos

    # Elentaure 26 de February de 2006 a las 18:17

  5. A Elanture,

    es bastante raro lo que comentas, podrías probar a pedir prestado a algún amigo un ratón y teclado USB a ver si de esa forma no se te cuelga.

    # Hugo 26 de February de 2006 a las 18:22

  6. bueno muchas gracias, de todas formas luego estuve leyendo en mas paginas y en una ponia como requisitio que el teclado y raton debian ser usb, asike me comprare un cable conversor y a probar otra vez.

    saludos.

    # Elentaure 26 de February de 2006 a las 20:58

  7. Yo tengo un problema.Tengo una imagen, despues de muchos intentos buena.Probe con VMWare y sin problemas.Ahora bien, al llebarlo a la practica e instalarlo en mi pc consegui instalarlo, pero al arrancar me pone “invalid partition table” y no puedo usar nada, ni windows ni MacOs, alguien me puede ayudar?? Podria instalarlo en un disco duro externo?

    # Tibadoc 26 de February de 2006 a las 22:16

  8. Hola de nuevo, creoq ue nadie contesta pero a ver si alguien me sabe decir algo, en el disco duro externo me sige pasando lo mismo, al arrancar me pone “invalid partition table” y no sigue, me hace lo mismo tanto si lo instalo en el disco duro del portatil como el externo y ya no se que hacer.Alguien me sabe decir a que es devido??que devo hacer??

    # Tibadoc 3 de March de 2006 a las 02:17

  9. En mi caso se cuelga porque no me lee del DVD. Que solucion hay para esto. Tengo un AMD Turion

    # Monica 3 de March de 2006 a las 21:43

  10. Hola,
    Mi problema es que cuando estoy en la instalacion, no me deja formatear la particion en la que quiero instalar el SO, de hecho no me deja escoger ninguna…Todas me aperece en gris claro y cuando le doy a ERASE parece que hace algo, pero cuando intento elegir la partición no me aparece nada.

    ¿Cómo tienen que ser las particiones para poder escogerlas? Un saludo

    # YoMisma 4 de March de 2006 a las 18:31

  11. me baje la imagen dmg de marklar-tiger.dmg la converti a iso con ultraiso le di un check con md5 y el md5 hash me dio correcto pache con el que sale en el enlace de macuarium y lo queme en un dvd pero al iniciar desde dvd, se queda en la pantalla de la manzana o a veces me da un error que me dise que apage el pc, pense que lo habia echo mal y pero la imagen iso del instalador lo arranque desde pear pc y corre pero no puedo instalar me da error grave y alli queda no se que pueda ser
    mi procesador es intel p IV HT 3.2ghz y tiene las intrucciones sse3 el chipset es ati y la tarjeta de video es ati radeon 9000 igp 512 en ram ddr y una particion primaria sin formatear de 10 gb, me pueden ayudar

    # Felipe X 7 de March de 2006 a las 00:03

  12. hola,estoy usando vmware entra a la instalacion perfectamente, pero el instalador de osx no ve ningun disco, ni sata ni ata. tengo un sata de 250gb y un ata de 30gb, el ata esta formateado como ntfs y vacio, pero el instalador solo ve el dvd desde donde esta instalando y nadamas, alguna sugerencia??

    si lo intento instalar desde el dvd sin vmware empieza a cargar y dice, tiene que reiniciar el equipo, asi siempre.

    placa gigabyte 8n sli royal
    nvidia 6600 gt

    # ant 7 de March de 2006 a las 04:20

  13. Buenas, a ver:
    ya instale el macos(10.4.1) en una particion de mi disco (no primaria), pero no consigo ni arrancarla desde el dvd (cuando le digo que arranque desde donde esta instalada, reinicia y me arranca xp, again).
    he decidido finalmente que cuando me haga con la 10.4.4 la instalare en el primario, y despues metere el xp…
    Lo que me interesa, mientras tanto es esto del boot.ini y añadir el chain0. Pero en mi dvd os X, no esta, y no se donde conseguirlo… ¿alguna ayuda?

    # Edu 7 de March de 2006 a las 20:53

  14. tengo el photoshop cs en ingles para mac os x. k tengo que hacer para; qué tengo que hacer para traducirlo al español?¿

    # rafa 7 de March de 2006 a las 23:17

  15. Prueba a apuntarte a Opening.

    Creo que voy a cerrar los comentarios de esta entrada porque está completamente desmadrado, hay 114 comentarios plagados de problemas que no soy capaz de solucionar.

    # Hugo 7 de March de 2006 a las 23:22